CVE-2026-42208LiteLLM: SQL injection in Proxy API key verification
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. From version 1.81.16 to before version 1.83.7, a database query used during proxy API key checks mixed the caller-supplied key value into the query text instead of passing it as a separate parameter. An unauthenticated attacker could send a specially crafted Authorization header to any LLM API route (for example POST /chat/completions) and reach this query through the proxy's error-handling path. An attacker could read data from the proxy's database and may be able to modify it, leading to unauthorised access to the proxy and the credentials it manages. This issue has been patched in version 1.83.7.
Overview
Severity
| Score | Severity | Version | Vector String |
|---|---|---|---|
| 9.3 | CRITICAL | 4.0GitHub_M (CNA) | CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N |
| 9.8 | CRITICAL | 3.1NVD | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H |
CISA required action
⚡ Known exploited · remediation due May 11, 2026
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Details
- CVE ID
- CVE-2026-42208
- Status
- Analyzed
- Assigner (CNA)
- GitHub_M
- Published
- May 8, 2026
- Last modified
- 2026-10-26 20:10 UTC
- Weaknesses
- CWE-89 · Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')
Affected Products
As published by the CNA in the CVE record.
BerriAIlitellm1 version range
- >= 1.81.16, < 1.83.7
References
- github.com https://github.com/BerriAI/litellm/releases/tag/v1.83.7-stable
- github.com https://github.com/BerriAI/litellm/security/advisories/GHSA-r75f-5x8p-qvmc
- access.redhat.com https://access.redhat.com/security/cve/CVE-2026-42208
- bugzilla.redhat.com https://bugzilla.redhat.com/show_bug.cgi?id=2463965
- security.access.redhat.com https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-42208.json
- cisa.gov https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-42208