CVE-2026-34197Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Authenticated users could perform RCE via Jolokia MBeans
Improper Input Validation, Improper Control of Generation of Code ('Code Injection') vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ. Apache ActiveMQ Classic exposes the Jolokia JMX-HTTP bridge at /api/jolokia/ on the web console. The default Jolokia access policy permits exec operations on all ActiveMQ MBeans (org.apache.activemq:*), including BrokerService.addNetworkConnector(String) and BrokerService.addConnector(String). An authenticated attacker can invoke these operations with a crafted discovery URI that triggers the VM transport's brokerConfig parameter to load a remote Spring XML application context using ResourceXmlApplicationContext. Because Spring's ResourceXmlApplicationContext instantiates all singleton beans before the BrokerService validates the configuration, arbitrary code execution occurs on the broker's JVM through bean factory methods such as Runtime.exec(). This issue affects Apache ActiveMQ Broker: before 5.19.4, from 6.0.0 before 6.2.3; Apache ActiveMQ All: before 5.19.4, from 6.0.0 before 6.2.3; Apache ActiveMQ: before 5.19.4, from 6.0.0 before 6.2.3. Users are recommended to upgrade to version 5.19.4 or 6.2.3, which fixes the issue
Overview
Severity
| Score | Severity | Version | Vector String |
|---|---|---|---|
| 8.8 | HIGH | 3.1CISA-ADP | CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H |
CISA required action
⚡ Known exploited · remediation due Apr 30, 2026
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Details
- CVE ID
- CVE-2026-34197
- Status
- Analyzed
- Assigner (CNA)
- apache
- Published
- Apr 7, 2026
- Last modified
- 2026-10-26 22:10 UTC
Affected Products
As published by the CNA in the CVE record.
Apache Software FoundationApache ActiveMQ Broker2 version ranges
- before 5.19.4
- 6.0.0 before 6.2.3
Apache Software FoundationApache ActiveMQ All2 version ranges
- before 5.19.4
- 6.0.0 before 6.2.3
Apache Software FoundationApache ActiveMQ2 version ranges
- before 5.19.4
- 6.0.0 before 6.2.3
References
- activemq.apache.org https://activemq.apache.org/security-advisories.data/CVE-2026-34197-announcement.txt
- openwall.com http://www.openwall.com/lists/oss-security/2026/04/06/3
- access.redhat.com https://access.redhat.com/security/cve/CVE-2026-34197
- bugzilla.redhat.com https://bugzilla.redhat.com/show_bug.cgi?id=2455869
- security.access.redhat.com https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-34197.json
- cisa.gov https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2026-34197