← CVE Radar
CVE-2025-32432Craft CMS Allows Remote Code Execution
Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. Starting from version 3.0.0-RC1 to before 3.9.15, 4.0.0-RC1 to before 4.14.15, and 5.0.0-RC1 to before 5.6.17, Craft is vulnerable to remote code execution. This is a high-impact, low-complexity attack vector. This issue has been patched in versions 3.9.15, 4.14.15, and 5.6.17, and is an additional fix for CVE-2023-41892.
10.0 CRITICALEPSS 99.79%⚡ Known Exploited (CISA KEV)NVD: Analyzed
Overview
Severity
| Score | Severity | Version | Vector String |
|---|---|---|---|
| 10.0 | CRITICAL | 3.1GitHub_M (CNA) | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:L |
| 10.0 | CRITICAL | 3.1NVD | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H |
CISA required action
⚡ Known exploited · remediation due Apr 3, 2026
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Details
- CVE ID
- CVE-2025-32432
- Status
- Analyzed
- Assigner (CNA)
- GitHub_M
- Published
- Apr 25, 2025
- Last modified
- 2026-09-24 13:10 UTC
- Weaknesses
- CWE-94 · Improper Control of Generation of Code ('Code Injection')
Affected Products
As published by the CNA in the CVE record.
craftcmscms3 version ranges
- >= 3.0.0-RC1, < 3.9.15
- >= 4.0.0-RC1, < 4.14.15
- >= 5.0.0-RC1, < 5.6.17
References
- github.com https://github.com/craftcms/cms/blob/3.x/CHANGELOG.md#3915---2025-04-10-critical
- github.com https://github.com/craftcms/cms/blob/4.x/CHANGELOG.md#41415---2025-04-10-critical
- github.com https://github.com/craftcms/cms/blob/5.x/CHANGELOG.md#5617---2025-04-10-critical
- github.com https://github.com/craftcms/cms/commit/e1c85441fa47eeb7c688c2053f25419bc0547b47
- github.com https://github.com/craftcms/cms/security/advisories/GHSA-f3gw-9ww9-jmc3
- sensepost.com https://sensepost.com/blog/2025/investigating-an-in-the-wild-campaign-using-rce-in-craftcms/
- cisa.gov https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-32432