CVE-2025-24813Apache Tomcat: Potential RCE and/or information disclosure and/or information corruption with partial PUT
Path Equivalence: 'file.Name' (Internal Dot) leading to Remote Code Execution and/or Information disclosure and/or malicious content added to uploaded files via write enabled Default Servlet in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.2, from 10.1.0-M1 through 10.1.34, from 9.0.0.M1 through 9.0.98. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. If all of the following were true, a malicious user was able to view security sensitive files and/or inject content into those files: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - a target URL for security sensitive uploads that was a sub-directory of a target URL for public uploads - attacker knowledge of the names of security sensitive files being uploaded - the security sensitive files also being uploaded via partial PUT If all of the following were true, a malicious user was able to perform remote code execution: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - application was using Tomcat's file based session persistence with the default storage location - application included a library that may be leveraged in a deserialization attack Users are recommended to upgrade to version 11.0.3, 10.1.35 or 9.0.99, which fixes the issue.
Overview
Severity
| Score | Severity | Version | Vector String |
|---|---|---|---|
| 10.0 | CRITICAL | 3.1CISA-ADP | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H |
| 9.8 | CRITICAL | 3.1NVD | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H |
CISA required action
⚡ Known exploited · remediation due Apr 22, 2025
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Details
- CVE ID
- CVE-2025-24813
- Status
- Analyzed
- Assigner (CNA)
- apache
- Published
- Mar 10, 2025
- Last modified
- 2026-06-17 08:59 UTC
Affected Products
As published by the CNA in the CVE record.
Apache Software FoundationApache Tomcat4 version ranges
- 11.0.0-M1 through 11.0.2
- 10.1.0-M1 through 10.1.34
- 9.0.0.M1 through 9.0.98
- 8.5.0 through 8.5.100
References
- lists.apache.org https://lists.apache.org/thread/j5fkjv2k477os90nczf2v9l61fb0kkgq
- openwall.com http://www.openwall.com/lists/oss-security/2025/03/10/5
- lists.debian.org https://lists.debian.org/debian-lts-announce/2025/04/msg00003.html
- security.netapp.com https://security.netapp.com/advisory/ntap-20250321-0001/
- vicarius.io https://www.vicarius.io/vsociety/posts/cve-2025-24813-detect-apache-tomcat-rce
- vicarius.io https://www.vicarius.io/vsociety/posts/cve-2025-24813-mitigate-apache-tomcat-rce
- vicarius.io https://www.vicarius.io/vsociety/posts/cve-2025-24813-tomcat-detect-vulnerability
- vicarius.io https://www.vicarius.io/vsociety/posts/cve-2025-24813-tomcat-mitigation-vulnerability
- github.com https://github.com/absholi7ly/POC-CVE-2025-24813/blob/main/README.md
- cisa.gov https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-24813