← CVE Radar
CVE-2024-56145RCE when PHP `register_argc_argv` config setting is enabled in craftcms/cms
Craft is a flexible, user-friendly CMS for creating custom digital experiences on the web and beyond. Users of affected versions are affected by this vulnerability if their php.ini configuration has `register_argc_argv` enabled. For these users an unspecified remote code execution vector is present. Users are advised to update to version 3.9.14, 4.13.2, or 5.5.2. Users unable to upgrade should disable `register_argc_argv` to mitigate the issue.
9.3 CRITICALEPSS 97.48%⚡ Known Exploited (CISA KEV)NVD: Analyzed
Overview
Severity
| Score | Severity | Version | Vector String |
|---|---|---|---|
| 9.3 | CRITICAL | 4.0GitHub_M (CNA) | CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N |
| 9.8 | CRITICAL | 3.1NVD | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H |
CISA required action
⚡ Known exploited · remediation due Jun 23, 2025
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Details
- CVE ID
- CVE-2024-56145
- Status
- Analyzed
- Assigner (CNA)
- GitHub_M
- Published
- Dec 18, 2024
- Last modified
- 2026-06-17 08:11 UTC
- Weaknesses
- CWE-94 · Improper Control of Generation of Code ('Code Injection')
Affected Products
As published by the CNA in the CVE record.
craftcmscms3 version ranges
- >= 4.0.0-RC1, < 4.13.2
- >= 5.0.0-RC1, < 5.5.2
- >= 3.0.0, < 3.9.14
References
- github.com https://github.com/craftcms/cms/commit/82e893fb794d30563da296bca31379c0df0079b3
- github.com https://github.com/craftcms/cms/security/advisories/GHSA-2p6p-9rc9-62j9
- github.com https://github.com/Chocapikk/CVE-2024-56145
- cisa.gov https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2024-56145