BlogPHP2Shell Exploitation: How Secure.com Can Protect YouRead more
← CVE Radar

CVE-2024-51567CyberPanel Incorrect Default Permissions Vulnerability

upgrademysqlstatus in databases/views.py in CyberPanel (aka Cyber Panel) before 5b08cd6 allows remote attackers to bypass authentication and execute arbitrary commands via /dataBases/upgrademysqlstatus by bypassing secMiddleware (which is only for a POST request) and using shell metacharacters in the statusfile property, as exploited in the wild in October 2024 by PSAUX. Versions through 2.3.6 and (unpatched) 2.3.7 are affected.

10.0 CRITICALEPSS 84.40%⚡ Known Exploited (CISA KEV)NVD: Analyzed

Overview

Severity

ScoreSeverityVersionVector String
10.0CRITICAL3.1mitre (CNA)CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
10.0CRITICAL3.1mitre (CNA)CVSS:3.1/AC:L/AV:N/A:H/C:H/I:H/PR:N/S:C/UI:N
9.8CRITICAL3.1NVDCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

CISA required action

⚡ Known exploited · remediation due Nov 28, 2024

Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.

Details

CVE ID
CVE-2024-51567
Status
Analyzed
Assigner (CNA)
mitre
Published
Oct 29, 2024
Last modified
2026-08-04 05:16 UTC
Weaknesses

Sources

Refreshed hourly from the sources above. Last fetched 2026-11-08 12:41 UTC.