CVE-2023-33246Apache RocketMQ: Possible remote code execution vulnerability when using the update configuration function
For RocketMQ versions 5.1.0 and below, under certain conditions, there is a risk of remote command execution. Several components of RocketMQ, including NameServer, Broker, and Controller, are leaked on the extranet and lack permission verification, an attacker can exploit this vulnerability by using the update configuration function to execute commands as the system users that RocketMQ is running as. Additionally, an attacker can achieve the same effect by forging the RocketMQ protocol content. To prevent these attacks, users are recommended to upgrade to version 5.1.1 or above for using RocketMQ 5.x or 4.9.6 or above for using RocketMQ 4.x .
Overview
Severity
| Score | Severity | Version | Vector String |
|---|---|---|---|
| 9.8 | CRITICAL | 3.1NVD | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H |
CISA required action
⚡ Known exploited · remediation due Sep 27, 2023
Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
Details
- CVE ID
- CVE-2023-33246
- Status
- Analyzed
- Assigner (CNA)
- apache
- Published
- May 24, 2023
- Last modified
- 2026-06-17 06:01 UTC
- Weaknesses
- CWE-94 · Improper Control of Generation of Code ('Code Injection')
Affected Products
As published by the CNA in the CVE record.
Apache Software FoundationApache RocketMQ1 version range
- through 5.1.0
References
- packetstormsecurity.com http://packetstormsecurity.com/files/173339/Apache-RocketMQ-5.1.0-Arbitrary-Code-Injection.html
- openwall.com http://www.openwall.com/lists/oss-security/2023/07/12/1
- lists.apache.org https://lists.apache.org/thread/1s8j2c8kogthtpv3060yddk03zq0pxyp
- vicarius.io https://www.vicarius.io/vsociety/posts/rocketmq-rce-cve-2023-33246-33247
- github.com https://github.com/Malayke/CVE-2023-33246_RocketMQ_RCE_EXPLOIT
- github.com https://github.com/jakabakos/CVE-2023-33246_Apache_RocketMQ_RCE
- cisa.gov https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2023-33246