← CVE Radar
CVE-2021-21311SSRF in adminer
Adminer is an open-source database management in a single PHP file. In adminer from version 4.0.0 and before 4.7.9 there is a server-side request forgery vulnerability. Users of Adminer versions bundling all drivers (e.g. `adminer.php`) are affected. This is fixed in version 4.7.9.
7.2 HIGHEPSS 98.46%⚡ Known Exploited (CISA KEV)NVD: Analyzed
Overview
Severity
| Score | Severity | Version | Vector String |
|---|---|---|---|
| 7.2 | HIGH | 3.1GitHub_M (CNA) | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N |
| 6.4 | MEDIUM | 2.0NVD | AV:N/AC:L/Au:N/C:P/I:P/A:N |
CISA required action
⚡ Known exploited · remediation due Oct 20, 2025
Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.
Details
- CVE ID
- CVE-2021-21311
- Status
- Analyzed
- Assigner (CNA)
- GitHub_M
- Published
- Feb 11, 2021
- Last modified
- 2026-06-17 03:35 UTC
- Weaknesses
- CWE-918 · Server-Side Request Forgery (SSRF)
Affected Products
As published by the CNA in the CVE record.
vranaadminer1 version range
- >= 4.0.0, < 4.7.9
References
- github.com https://github.com/vrana/adminer/commit/ccd2374b0b12bd547417bf0dacdf153826c83351
- github.com https://github.com/vrana/adminer/files/5957311/Adminer.SSRF.pdf
- github.com https://github.com/vrana/adminer/security/advisories/GHSA-x5r2-hj5c-8jx6
- lists.debian.org https://lists.debian.org/debian-lts-announce/2021/03/msg00002.html
- packagist.org https://packagist.org/packages/vrana/adminer
- cisa.gov https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2021-21311