CVE-2019-11580Atlassian Crowd and Crowd Data Center Remote Code Execution Vulnerability
Atlassian Crowd and Crowd Data Center had the pdkinstall development plugin incorrectly enabled in release builds. Attackers who can send unauthenticated or authenticated requests to a Crowd or Crowd Data Center instance can exploit this vulnerability to install arbitrary plugins, which permits remote code execution on systems running a vulnerable version of Crowd or Crowd Data Center. All versions of Crowd from version 2.1.0 before 3.0.5 (the fixed version for 3.0.x), from version 3.1.0 before 3.1.6 (the fixed version for 3.1.x), from version 3.2.0 before 3.2.8 (the fixed version for 3.2.x), from version 3.3.0 before 3.3.5 (the fixed version for 3.3.x), and from version 3.4.0 before 3.4.4 (the fixed version for 3.4.x) are affected by this vulnerability.
Overview
Severity
| Score | Severity | Version | Vector String |
|---|---|---|---|
| 9.8 | CRITICAL | 3.1NVD | CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H |
| 7.5 | HIGH | 2.0NVD | AV:N/AC:L/Au:N/C:P/I:P/A:P |
CISA required action
⚡ Known exploited · remediation due May 3, 2022
Apply updates per vendor instructions.
Details
- CVE ID
- CVE-2019-11580
- Status
- Analyzed
- Assigner (CNA)
- atlassian
- Published
- Jun 3, 2019
- Last modified
- 2026-06-17 02:13 UTC
Affected Products
As published by the CNA in the CVE record.
AtlassianCrowd10 version ranges
- 2.1.0 before unspecified
- before 3.0.5
- 3.1.0 before unspecified
- before 3.1.6
- 3.2.0 before unspecified
- before 3.2.8
- 3.3.0 before unspecified
- before 3.3.5
- 3.4.0 before unspecified
- before 3.4.4
References
- packetstormsecurity.com http://packetstormsecurity.com/files/163810/Atlassian-Crowd-pdkinstall-Remote-Code-Execution.html
- securityfocus.com http://www.securityfocus.com/bid/108637
- jira.atlassian.com https://jira.atlassian.com/browse/CWD-5388
- cisa.gov https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2019-11580